script>@-vor dem namen<--probleme mit Chrome+Safari

Fragen zu HTML, CSS, eigenen Erweiterungen etc.
Benutzeravatar
ExEngel
Beiträge: 37
Registriert: 27.04.2010, 13:11
Wohnort: Waiblingen
Kontaktdaten:

script>@-vor dem namen<--probleme mit Chrome+Safari

Ungelesener Beitrag von ExEngel » 03.08.2013, 18:38

Hallo liebe Spezialisten,
bin heute im Chat von einigen Usern angesprochen worden,die Chrome oder Safari als Browser benutzen. Habe bei mir in der Ankündigung dieses Script eingebaut...
Script:Zeigen
<script type="text/javascript">function schreibeAt(){divs = parent.rightFrame.document.getElementsByTagName("div"); for(i=0;i<divs.length;i++){ if(divs.id && divs.id != "" && !divs.innerHTML.match("--@-> ")){ parent.rightFrame.document.getElementsByTagName("div").innerHTML = "<span onclick='parent.info.document.eingabe.message.value = \"\--@-> <font color=#FFFF00>"+divs.id+"</font>: \";parent.info.document.eingabe.message.focus();'>--@-> </span>"+divs.innerHTML;}}} window.setInterval("schreibeAt()", 1000)</script>
.
Bei diesen Usern, die Chrome oder Safari benutzen, erscheinen in der Onlineliste immer mehr der "@" -Zeichen.Solange bis nur noch diese Zeichen und gar keine Nicks mehr zu sehen sind.
Bei allen anderen Browsern funzt es einwandfrei ohne irgendwelche Probleme. Habe schon sämtliche anderen Scripte mal raus gehabt, um zu sehen, ob es da einen Konflikt gibt, aber auch wenn nur dieses eine Script drin ist, erscheint dieser Fehler.
Wäre nett, wenn sich das mal jemand anschauen und eventuell fixen könnte.

Im Voraus vielen Dank

Euer Exengel
Zuletzt geändert von ZischDings am 03.08.2013, 18:45, insgesamt 1-mal geändert.
Grund: Script-Probleme bitte nicht nach Probleme/Bugs! Thema verschoben ins richtige Forum.
erstens kommt es anders.....zweitens als man denkt

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 8 Gäste